[poj3263]Tallest Cow

题目

题目描述

FJ’s N (1 ≤ N ≤ 10,000) cows conveniently indexed 1..N are standing in a line. Each cow has a positive integer height (which is a bit of secret). You are told only the height H (1 ≤ H ≤ 1,000,000) of the tallest cow along with the index I of that cow.

FJ has made a list of R (0 ≤ R ≤ 10,000) lines of the form “cow 17 sees cow 34”. This means that cow 34 is at least as tall as cow 17, and that every cow between 17 and 34 has a height that is strictly smaller than that of cow 17.

For each cow from 1..N, determine its maximum possible height, such that all of the information given is still correct. It is guaranteed that it is possible to satisfy all the constraints.

输入

Line 1: Four space-separated integers: N, I, H and R
Lines 2..R+1: Two distinct space-separated integers A and B (1 ≤ A, B ≤ N), indicating that cow A can see cow B.

输出

Lines 1..N: Line i contains the maximum possible height of cow i.

输入样例

1
2
3
4
5
6
9 3 5 5
1 3
5 3
4 3
3 7
9 8

输出样例

1
2
3
4
5
6
7
8
9
5
4
5
3
4
4
5
5
5

来源

USACO 2007 January Silver

传送门

Tallest Cow

题解

代码

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
#include<iostream>
#include<cstdio>
#include<map>
using namespace std;
int d[100001];
unsigned int s[100001];
int n,i,h,r;
int x,y;
map<pair<int,int>,bool> judge;

int main(){
scanf("%d%d%d%d",&n,&i,&h,&r);
d[1]=h;
for(int i=1;i<=r;i++){
scanf("%d%d",&x,&y);
if(x>y)swap(x,y);
if(judge[make_pair(x,y)])continue;
d[x+1]--,d[y]++;
judge[make_pair(x,y)]=1;
}
for(int i=1;i<=n;i++){
s[i]=s[i-1]+d[i];
}
for(int i=1;i<=n;i++){
printf("%d\n",s[i]);
}
return 0;
}